"prodigy: command not found" after installation (Linux)

Hi,

I installed via ‘pip install prodigy…whl’ on Linux. It seems to install okay:

....
Successfully built peewee hug mmh3
Installing collected packages: peewee, python-mimeparse, falcon, hug, waitress, cachetools, mmh3, hug-middleware-cors, prodigy
Successfully installed cachetools-3.1.0 falcon-1.4.1 hug-2.4.1 hug-middleware-cors-1.0.0 mmh3-2.5.1 peewee-2.10.2 prodigy-1.6.1 python-mimeparse-1.6.0 waitress-1.2.1
You are using pip version 9.0.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

It seems to have installed okay but when I run prodigy the command is not found. I’m on RHEL 7. I can see the pip package was installed as it is listed in pip list.

bash-4.2$ prodigy dataset financial "Financial terms" --author "David Doherty"
bash: prodigy: command not found
bash-4.2$ pip3 list | grep "gy"
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
pluggy (0.8.1)
prodigy (1.6.1)
You are using pip version 9.0.1, however version 19.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
bash-4.2$ prodigy
bash: prodigy: command not found
bash-4.2$ python3
Python 3.6.1 (default, Jan  2 2019, 14:30:39)
[GCC 7.1.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import prodigy
>>> prodigy.
prodigy.about             prodigy.get_recipe(       prodigy.recipe_args       prodigy.unicode_literals
prodigy.app               prodigy.get_schema(       prodigy.recipes           prodigy.util
prodigy.components        prodigy.get_stream(       prodigy.serve(            prodigy.warnings
prodigy.core              prodigy.log(              prodigy.server(
prodigy.get_config(       prodigy.models            prodigy.set_hashes(
prodigy.get_loader(       prodigy.recipe(           prodigy.set_recipe(

Where is the prodigy script installed? Do I need to set up the symlink myself or should the install script have done this for me?

Thanks,
Dave

It should be installed by default, but it sometimes isn’t. But you can always run python -m prodigy instead or set the alias yourself. (That’s pretty much all that script is doing anyways.)

1 Like

Thanks. I’m on a shared server so the path setup is a bit weird, but your suggestion worked like a charm. Thanks!

Hi! I have the same problem but in my case python -m prodigy doesn't work either. I still get prodigy: command not found.

My steps:

conda create --name prodigy
conda activate prodigy
pip install spacy
python -m spacy download en_core_web_sm
python -m spacy validate
======== Installed models (spaCy v2.3.5) =========
:information_source: spaCy installation:
/Applications/anaconda3/envs/prodigy/lib/python3.9/site-packages/spacy
TYPE NAME MODEL VERSION
package en-core-web-sm en_core_web_sm 2.3.1 :heavy_check_mark:
pip install /Downloads/prodigy-1.10.8-cp36.cp37.cp38-cp36m.cp37m.cp38-macosx_10_14_x86_64.whl
python -m prodigy stats
/Applications/anaconda3/envs/prodigy/bin/python: No module named prodigy

I think I have messed up my environments but not sure where to look to fix it. Any suggestions please?

Hi! Can you share how you've installed the Prodigy wheel? In the example you posted above, it only shows the installation of spaCy, but not the installation of Prodigy.

The line was there but blurred into pervious lines. Sorry about that.

And pip list | grep "prodigy" yields prodigy 1.10.8

Ah, thanks for the clarification. What do you see when you run which python? Maybe the python you're using to execute Prodigy in this environment is a different Python than the one pip/conda install into?

Also, I noticed that the Python version is 3.9, but the Prodigy wheel only supports 3.6, 3.7 and 3.8. So I'm surprised the installation succeeded :thinking: Can you try with a 3.8 environment?

Yeah, I didn't notice that python under conda in 3.9... which python points to /Applications/anaconda3/envs/prodigy/bin/python. I managed to run prodigy with python3.7 though.