Win10, AMD64: prodigy 1.4.2 requires hug, hug-middleware-cors, peewee, mmh3

Installed spacy with conda in an virtual environment on Windows 10, Python 3.6.
Run the basic tests on spacy which looked OK.
Tried to install the prodigy wheel (prodigy-1.4.2-cp35.cp36-cp35m.cp36m-win_amd64.whl) which told me, that it is an incompatible version.
Then simply unpacked the folders

prodigy
prodigy-1.4.2.dist-info
to the site-packages folder of the virtEnv.

Result:
prodigy 1.4.2 requires hug<3.0.0,>=2.2.0, which is not installed.
prodigy 1.4.2 requires hug-middleware-cors<2.0.0,>=1.0.0, which is not installed.
prodigy 1.4.2 requires mmh3<3.0,>=2.4, which is not installed.
prodigy 1.4.2 has requirement peewee<3.0.0,>=2.10.1, but you’ll have peewee 3.2.5 which is incompatible.

How to proceed?

I think I’m running into the same issue, also on win10 with python 3.6. Seems like all the wheels are failing with this error:
" copying hug_init_.py -> build\lib.win-amd64-3.6\hug
running build_ext
cythoning hug\api.py to hug\api.c
building ‘hug.api’ extension
creating build\temp.win-amd64-3.6
creating build\temp.win-amd64-3.6\Release
creating build\temp.win-amd64-3.6\Release\hug
C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.13.26128\bin\HostX86\x64\cl.exe /c /nologo /Ox /W3 /GL /DNDEBUG /MD -Ic:\programdata\anaconda3\include -Ic:\programdata\anaconda3\include “-IC:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.13.26128\include” /Tchug\api.c /Fobuild\temp.win-amd64-3.6\Release\hug\api.obj
api.c
c:\programdata\anaconda3\include\pyconfig.h(59): fatal error C1083: Cannot open include file: ‘io.h’: No such file or directory
error: command ‘C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools\VC\Tools\MSVC\14.13.26128\bin\HostX86\x64\cl.exe’ failed with exit status 2


Failed building wheel for hug"

This seems to be something related to environmental variables between pip and visual studio?

As an additional note, I accidentally installed visual build tools 2017 instead of 15 on this particular machine.

@Ralf @rmeier What version of spaCy do you install via conda? Are you able to install Prodigy if you start from a clean environment, without installing spaCy first?

Hrm, it seems that if I install the full visual studio community edition 2017 with the C++ toolset (5.6gb install) the whl compiles successfully. It didn’t work with either the 2015 or 207 C++ build tools alone

… not able to post an answer:
“Sorry, new users can only put 2 links in a post.”

This is really anoing!!!
I can not post anything more than several lines of text. Will go ahead with screen captures.

@honnibal: Tried today to install prodigy into a clean conda virtual environment, without spacy. It did work, except 1 point:

sphinx 1.3.1 has requirement sphinx_rtd_theme<0.2,>=0.1, but you'll have sphinx-rtd-theme 0.2.4 which is incompatible.

I installed sphinx via ‘python -m install sphinx’ which worked fine.

Then I fired up python :

@Ralf About the links: The Discourse software that runs the forum adds some constraints on the number of links in the text. If you post your tracebacks and logs as string literals in between three backticks (```), it should work. Otherwise screenshots work too.

The Sphinx software is not a dependency of Prodigy, so I’m really confused as to how it’s coming up. From your log, are you sure you’re installing everything into the same environment? Above, you’re deactivating the environment spacy_e, and then activating the environment prodi.gy. Is that what you intended to do?

It also looks like your Anaconda installation has problems — you’re getting unicode errors as oon as you run Python, right? So it seems like something is really wrong with your installation.