Prodigy installation error

pip install prodigy-1.5.1-cp35.cp36-cp35m.cp36m-linux_x86_64.whl completes, however, it shows the following error.

Successfully built peewee hug msgpack-python mmh3 thinc spacy ujson toolz numpy msgpack murmurhash cymem preshed cytoolz wrapt dill regex
spacy 2.0.16 has requirement cymem<2.1.0,>=2.0.2, but you'll have cymem 1.31.2 which is incompatible.
spacy 2.0.16 has requirement preshed<2.1.0,>=2.0.1, but you'll have preshed 1.0.1 which is incompatible.
spacy 2.0.16 has requirement thinc<6.13.0,>=6.12.0, but you'll have thinc 6.10.3 which is incompatible.

While running prodigy, I get the following error

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/", line 183, in _run_module_as_main
    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
  File "/usr/local/lib/python3.6/", line 142, in _get_module_details
    return _get_module_details(pkg_main_name, error)
  File "/usr/local/lib/python3.6/", line 109, in _get_module_details
  File "/usr/local/lib/python3.6/site-packages/prodigy/", line 4, in <module>
    from . import recipes  # noqa
  File "/usr/local/lib/python3.6/site-packages/prodigy/recipes/", line 4, in <module>
    from . import dep, ner, textcat, pos, compare, terms, generic, image  # noqa
  File "/usr/local/lib/python3.6/site-packages/prodigy/recipes/", line 5, in <module>
    import spacy
  File "/usr/local/lib/python3.6/site-packages/spacy/", line 8, in <module>
    from thinc.neural.util import prefer_gpu, require_gpu
ImportError: cannot import name 'prefer_gpu'

I have successfully installed and running prodigy in another machine. Looks like it is happening because prodigy install is picking latest spacy and that gives the above mentioned error?

Currently, the workaround I am using is as follows. However, nice if prodigy locks to the correct version of spacy which will work

    pip uninstall spacy
    pip install 'spacy==2.0.12'

Sorry about that – this is only temporary but a necessary update we had to make! See here for details:

Copying over the relevant part ("tomorrow" = today, since that post was from yesterday):

Apologies for this, but it's a consequence of pip's compromises between efficiency and fidelity in version resolution. Pip processes dependencies in order, and doesn't backtrack if it comes to a dependency conflict.

We'll be releasing a version 1.6.0 of Prodigy tomorrow, which will resolve the version conflict. While we understood that this update could cause problems, it was necessary to support Python 3.7, and also to upload binary wheels for spaCy and its dependent packages.