Config file not saving over - ERRNO 99

Hello, I have an EC2 instance running the jupyter-prodigy extension. I recently had to stop and restart our instance to expand our RAM and now I am unable to redirect to the new ip address.

I receive this error:
ERROR: [Errno 99] error while attempting to bind on address ('MY.OLD.IP.ADDRESS', 8080): cannot assign requested address
where MY.OLD.IP.ADDRESS is my original redirected ipv4 host that I set up using the prodigy.json file.

HOWEVER, after restarting my instance, my old ipv4 has since dissipated and a new one was assigned to my EC2 instance which is all well and good, so I edited my prodiy.json file to point at the NEW "host" address. However, it doesn't seem to be working. The file is saved, I can see the config file with the NEW host in it, yet whenever I try to run prodigy, it's attempting to use the OLD ip address for the host.

Why is my config file not working? Is there a way to force the IP address?

Below is my prodigy.json
GNU nano 6.2 prodigy.json
"host": "",
"total_examples_target": 200,
"exclude_by": "input"

The same is set up in the Jupyter Lab extended settings for Prodigy. My changes are not saving and I am unable to get prodigy to run again

Hi @WKamptner!

Thanks for your message and welcome to the Prodigy community :wave:

I don't see any issues with your config file.

However, it's very easy to sometimes have multiple config files or overrides and not realize it.

Have you tried to manually override the "host"?

This can sometimes override whichever prodigy.json and be explicit on the changes. This should work as a short term.

Note, you can also provide your override as a prefix for your commands too:

PRODIGY_CONFIG_OVERRIDES='{"host": "ec2-MY-..."}' python -m prodigy ...

You can also use these overrides to "reset" your config:

Also, have you tried Prodigy logging? Consider using it as verbose as it should give you reference of what prodigy.json you're loading, perhaps seeing where you're loading a config you weren't intending for.

Other users have reported ERRNO 99 issue because they had to restart/end and accidentally didn't realize something else was also running:

Just curious, can you run Prodigy w/o the jupyter-prodigy extension? I want to diagnose if the issue simply Prodigy or the extension.

Like the earlier post, one way to test is to try a different port. This can sometimes be an issue with jupyter-prodigy extension so that's why perhaps you could try a different port with only Prodigy run from a terminal.

Let me know if either of these help or if you're still having issues.