I'm setting up prodigy on an AWS account, so I was trying to switch the host port as recommended here (Can't access prodigy from outside aws machine - #3 by davebulaval)

but when I run export PRODIGY_CONFIG_OVERRIDES=‘{“host”: “”}’ I get this error: bash: export: `“”}’': not a valid identifier

So then I found the config file and changed it manually, but now even when I run the original prodigy recipe, I keep getting this error:
✘ Can't load overrides from env variable PRODIGY_CONFIG_OVERRIDES:
invalid JSON. Make sure to use double quotes in your overrides.

Is it possible to "undo" the prodigy_config_overrides? Or re-set it somehow? I'm sorry if this is a silly mistake/question, I'm very new to this.

Thanks in advance for your help!

Hi! Since you've used export, the environment variable has been set for the whole session, so one option would be to just set export PRODIGY_CONFIG_OVERRIDES="{}" to reset it to an empty dict.

I'm not sure if this happened while copy-pasting or if this was the actual output, but based on the error message, it looks like you somehow ended up with typographic quotes, e.g. instead of "? So that's the first thing I would check. If you want to be extra sure, you can also run echo $PRODIGY_CONFIG_OVERRIDES and then copy-paste the output to Python's json.loads as a string. If that succeeds, it should be valid.

1 Like

thank you so much!! This is exactly what I needed.

1 Like