Can't save annotations - problem with thinc?

Hi!

I am trying to annotate to train a text classifier with textcat.teach. I am able to load in the data and start annotating. But as soon as I want to save my annotations it gives me the error (in the gui) that it can’t save them and that I have to check if the database is connected correctly.

The error message I get in the terminal is the following though:

It seems like something is not working with the model in the background. Has anyone seen this before?

I created a new conda environment and only installed prodigy with its dependencies there. I tried python 3.6 and 3.7 and in both it doesn’t work.

Thanks for your help!

I’m having this problem too. Tried it with our own dataset as well as with this sample dataset.

@Noe @alexkearns That’s definitely strange :thinking: Could you run pip list and check which versions of Prodigy, spaCy and Thinc you’re running? (We just released a new version of Thinc yesterday and I wonder if this is some side-effect of this.)

I am running the following versions:

  • prodigy: 1.8.3
  • spaCy: 2.1.4
  • thinc: 7.0.5

Thanks, pretty sure this is the problem then! So sorry about that – the update was actually supposed to fix bugs in the text classifier and make it more robust :sob: Currently working on a fix and test and will push Thinc v7.0.6 asap!

In the meantime, downgrading Thinc should do the trick: pip install thinc==7.0.4.

1 Like

With thinc==7.0.4 it works. Thanks a lot for your help!!

1 Like

Works for me too with the temporary fix. Thanks for the quick reply :slight_smile:

1 Like

You should now also be able to run pip install -U thinc to use the very latest version that resolves the problem :slightly_smiling_face:

1 Like