Upgrade installation issue

I cannot install the upgrade with the command

pip install prodigy -f https://XXXX-XXXX-XXXX-XXXX@download.prodi.gy

I have put in my license key for the x's.

After running command I do prodigy stats
Version 1.12.5
Location /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages/prodigy
Prodigy Home /Users/andreashegedus/.prodigy
Platform macOS-10.16-x86_64-i386-64bit
Python Version 3.9.13
Spacy Version 3.6.1
Database Name SQLite
Database Id sqlite

Interestingly I am running MacOs 13.4.1 not 10.16

I think this is related to a previous issue where I hade to rename the whl file
as an example to install .12.5
I needed to rename

There are previous topics from me where we worked on this work around.
How can I install the upgrade?

hi @andyhegedus,

Can you try to add --upgrade?

pip install --upgrade prodigy -f https://XXXX-XXXX-XXXX-XXXX@download.prodi.gy

Yes, here's the link from our previous thread where the problem was Intel Mac.

Alternatively, instead of running pip install (which will automatically choose the wheel file for you), you can now choose and download a specific wheel file by putting https://XXXX-XXXX-XXXX-XXXX@download.prodi.gy into a browser, and then you'll see all of the versions of Prodigy you are eligible to get.

Then can you try to do the same steps we previously went thru in renaming the wheel file above?


I tried adding --upgrade
Same result still at 1.12.5
I tried going directly to the website as you suggested. I am greeted with a login panel with user id and password. What should I use?

You can put your license key in user id.

Hopefully you shouldn't need to put in the user id though if you type into the browser: https://xxxx-xxxx-xxxx-xxxx@download.prodi.gy, not https://download.prodi.gy. But worst case using the license key in user id should suffice. (FYI my screen shot showed https://download.prodi.gy because after it takes your license key, it'll only show https://download.prodi.gy).


I used license key for both fields and that worked. Download 1.13.1 appropriate whl file, renamed as before and it installed.

1 Like

Excellent - I'm so glad it worked out :smiley:

Enjoy trying out v1.13! By the way, we're planning more updates in the upcoming weeks so hopefully this workflow will work again for any future updates!