Installing update 1.11.110 on Mac

Pardon my ignorance, I received an email with notification of an update version 1.11.10 and clicked the download button. It downloaded a folder entitled "mac" with several .whl files. What is the next step in installation?

hi @andyhegedus!

The easiest is to install Prodigy via wheel per these instructions.

pip install prodigy-1.11.10-cp...

Alternatively, you can skip the wheel files and use your Prodigy license key instead and install Prodigy via PyPi too (see these instructions), where XXXX-XXXX-XXXX-XXXX is your Prodigy license key.

pip install prodigy -f

Pardon the ignorance. I got a message for the latest version and clicked the download. I received a folder "mac" with some .whl files. Using your decoder and double checking my python installation.
version 3.9.13 on an Intel Mac running Ventura (13.1) I issued this command in terminal.

pip install /path_to_fiile/prodigy-1.11.10-cp39-cp39-macosx_11_0_x86_64.whl
which gave me the "not support platform error"

I then tried:

pip install prodigy -f /path/to/wheels

where path to wheels is the dowloaded folder that came from the email which contained only version 1.11.10 .whl files.

It worked its way through but then removed spacy 3.5.0 and installed spacy 3.4.4. and then gave me errors about the language libraries being incompatible. I think it installed version 1.11.8 of prodigy. I did a prodigy stats command and it is saying it is version 1.11.8

"en-core-web-sm 3.5.0 requires spacy<3.6.0,>=3.5.0, but you have spacy 3.4.4 which is incompatible."

Where do I go from here?

I went ahead and combined these two issues.

What version of Python are you trying to use? This wheel file is for Python 3.9.

You can check your python version by running:

python --version

Yes, like it's mentioning, you installed Prodigy v1.11.8 and had spaCy 3.5.0. However, Prodigy v1.11.10 is the first version that supports spaCy 3.5.

I would recommend to start in a fresh virtual environment. if you're new to virtual environments, I recommend my colleague @koaning's tutorial video on virtual environments.

In your new virtual environment, first install Prodigy either via PyPi or wheel file. It should then automatically install spaCy 3.5.0 along with Prodigy 1.11.10 automatically.

Let me know if you have questions.

Hi Python Version is:
Python 3.9.13

I did the pip install with my key (Andy is substituted here for actual key)

pip install prodigy -f

It runs and downgrades my installation.

It looks like it is installing 1.11.8 not 1.11.11
and it then downgrades the my Spacy 3.5 to version 3.4

From terminal window:
First line

Looking in links: https://****
Requirement already satisfied: prodigy in ./opt/anaconda3/lib/python3.9/site-packages (1.11.8)

Installing collected packages: spacy
Attempting uninstall: spacy
Found existing installation: spacy 3.5.0
Uninstalling spacy-3.5.0:
Successfully uninstalled spacy-3.5.0
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
en-core-web-sm 3.5.0 requires spacy<3.6.0,>=3.5.0, but you have spacy 3.4.4 which is incompatible.
en-core-web-md 3.5.0 requires spacy<3.6.0,>=3.5.0, but you have spacy 3.4.4 which is incompatible.
Successfully installed spacy-3.4.4

I would prefer not to have a separate environment for Prodigy and Spacy so I would like to get this one working. This seems to be a fight between prodigy and spacy.


hi @andyhegedus!

Thanks for the update and sorry you're still having issues.

pip install prodigy -f

So the biggest problem is this should automatically install v1.11.10, not v1.11.8. I'm a bit stumped on why this would happen.

Can you first run:

pip install --upgrade pip

I doubt that would do it but there's definitely something wrong going on. I'm going to ask a few teammates but if we can get this to install correctly, then it'll relieve the spaCy-Prodigy conflicts as v1.11.10 was released to work with spaCy 3.5.

Just curious, did you try to install v1.11.10 directly via wheel file? Did that not work?

I did the pip upgrade

pip install --upgrade pip

And I am up to date version (23.0)

I then tried with the downloaded wheel files from attached to update email.:

pip install /Users/andreashegedus/Desktop/mac/prodigy-1.11.10-cp39-cp39-macosx_11_0_x86_64.whl

I have version 3.9.13 of python and it is an Intel Mac.

I get error.
ERROR: prodigy-1.11.10-cp39-cp39-macosx_11_0_x86_64.whl is not a supported wheel on this platform.


Thanks @andyhegedus!

It looks like there's an issue with either the file or pypi link for that version. We're going to look into this and get back to you in a few days (if not sooner).

Thanks again for your help for raising this issue!

Any update to report?

Hi Andy,

Thanks for bearing with us. It seems like the issue shows up on some Intel Macs on macOS Ventura but not on others, so we need to figure out what other system differences are responsible for that.
Would you be able to share the output of the following two commands with us?
uname -a
python -m pip debug --verbose
This last one is pretty long, but it lists all pip tags that are compatible with your system so we can check if it overlaps with the ones we have distributed. Thank you.

name -a
Darwin Andys-iMac.local 22.2.0 Darwin Kernel Version 22.2.0: Fri Nov 11 02:08:47 PST 2022; root:xnu-8792.61.2~4/RELEASE_X86_64 x86_64

I will split into two messages due character limits.
python -m pip debug --verbose
WARNING: This command is only meant for debugging. Do not use this with automation for parsing and getting these details, since the output and options of this command may change without notice.
pip version: pip 23.0 from /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages/pip (python 3.9)
sys.version: 3.9.13 (main, Aug 25 2022, 18:29:29)
[Clang 12.0.0 ]
sys.executable: /Users/andreashegedus/opt/anaconda3/bin/python
sys.getdefaultencoding: utf-8
sys.getfilesystemencoding: utf-8
locale.getpreferredencoding: UTF-8
sys.platform: darwin
name: cpython
'cert' config value: Not specified
pip._vendor.certifi.where(): /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages/pip/_vendor/certifi/cacert.pem
pip._vendor.DEBUNDLED: False
vendored library versions:
rich==12.6.0 (Unable to locate actual module version, using vendor.txt specified version)
typing_extensions==4.4.0 (Unable to locate actual module version, using vendor.txt specified version)
setuptools==44.0.0 (Unable to locate actual module version, using vendor.txt specified version)
tenacity==8.1.0 (Unable to locate actual module version, using vendor.txt specified version)
webencodings==0.5.1 (Unable to locate actual module version, using vendor.txt specified version)
Compatible tags: 1650

Part 2.

Thanks so much Andy.
It's very peculiar, but it seems that for some reason your system's pip does not recognize that it should support macosx_11.
Since pip is only looking at a filename when installing, I believe that re-naming the .whl file should do the job:

mv prodigy-1.11.10-cp39-cp39-macosx_11_0_x86_64.whl prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl
pip install -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

Hopefully, this unblocks you. Do let us know if it doesn't. We will definitely keep investigating what combination of factors causes this (it might even be a bug in pip similar to this one)

Here is what I have done:

  1. renamed file

  2. CD into that directory

  3. Validate that the file is there

  4. issue command:
    pip install -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

and get error:
ERROR: You must give at least one requirement to install (maybe you meant "pip install prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl"?)

Well that message wasn't helpful.
Any guidance?

Hi Andy,
The command in your step 4 should be:
pip install prodigy -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl
Apologies for the typo before.

Well something ran and did not return an error HOWEVER it looks like it didn't install anything.
Every line of the output to the terminal is showing "Requirement already satisfied" with the first line referencing version 1.11.8. It did not downgrade the spaCy version as before so that is some progress.

(base) andreashegedus@Andys-iMac mac % pip install prodigy -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

Looking in links: prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

Requirement already satisfied: prodigy in /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages (1.11.8)
Requirement already satisfied: pyjwt<3.0.0,>=2.0.0 in /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages (from prodigy) (2.4.0)
Requirement already satisfied: requests in /Users/andreashegedus/opt/anaconda3/lib/python3.9/site-packages (from prodigy) (2.28.1)

Is there a straight forward way to check the version that is installed?

Hi Andy,
Sorry to hear you're having troubles still!
It looks like the current problem is that you're trying to install in the conda environment that already has 1.11.8 installed.
The recommended way would be to create a fresh environment to try the 1.11.10 installation or to uninstall Prodigy in your base environment before installing another version. You can achieve that by using the --upgrade flag of pip. I'll provide the commands for both solutions:

In order to create a fresh conda environment & install 1.11.10:

conda create --name prodigy_env python=3.9 # you can of course change the name parameter
conda activate prodigy_env
pip install prodigy -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

In order to upgrade an existing 1.11.8 installation to 1.11.10 in your base environment:
With the base environment activated:

pip install --upgrade prodigy -f prodigy-1.11.10-cp39-cp39-macosx_10_15_x86_64.whl

In order to check which version of Prodigy has been installed in a given environment, with this environment activated, you can run:

prodigy stats

The first line of the output is the version of Prodigy.


Thank you.

You're very welcome. Thanks for reporting back :slight_smile:

I may have spoken too soon.

With your 1.11.11 update, it is not installed and stays at 1.11.10
I used

pip install --upgrade prodigy -f path/to/whl_file

it came back with
Looking in links: /Users/andreashegedus/Desktop/Tools/Spacy/update 1.11.11/prodigy-1.11.11-cp39-cp39-macosx_10_0_x86_64.whl
Requirement already satisfied: prodigy in ./opt/anaconda3/lib/python3.9/site-packages (1.11.10)

prodigy stats

Shows version is still 1.11.10