Trouble installing prodigy

Hello,

Having trouble installing prodigy.

Looking in links: https://****@download.prodi.gy
ERROR: Could not find a version that satisfies the requirement prodigy (from versions: none)
ERROR: No matching distribution found for prodigy

hi @flamit!

Thanks for your message and welcome to the Prodigy community :wave:

Sorry you're having this issue.

First try to upgrade pip:

pip install --upgrade pip

What version of Python are you using?

Older versions of Python don't have wheels set up for the newer version of Prodigy. Last year we released wheels for Python 3.10 and had them for 3.9 and 3.8.

Also, what operating system are you using? There can be some hiccups with Mac (M1) too.

Hopefully one of those will do the trick. There could be other issues -- you can search by the error message.

Let us know if you're able to work it out or not!

its python 3.11 so i should install 3.10 then ? im using windows. i think the problem is my version of python tho

yes! I don't think we have wheels for 3.11 just yet. We likely will add them very soon.