Prodigy installed but not running

I am trying to install Prodigy within a venv. It is installed via prodigy-1.10.6-cp36.cp37.cp38-cp36m.cp37m.cp38-linux_x86_64.whl and pip freeze shows the package (even installing it again manually indicates that the prodigy package is already installed)
Then python -m prodigy results in ImportError: cannot open shared object file: No such file or directory. I cannot find libpython through which (as indicated here or here). When running python within the venv, it also fails in importing prodigy. Could you help me with this?

In general, I recommend installing via python -m pip. That way, there's less virtualenv accidents that might happen (if you'd like to learn more you may enjoy this resource). I also recommend upgrading pip before installing anything. If I were to use the recent installation instructions you can install Prodigy via:

python -m pip install --upgrade pip
python -m pip install prodigy -f https://[license-key]

I'm currently assuming this might be a conda related thing, but could you let me know if the above installation instructions work for you? If not then I'll gladly dive in deeper.

Vincent, thank you so much for the prompt response. Pip is already at 22.1.2 and for python -m pip install prodigy (need to install the specific wheel) is already satisfied. Then I run again python -m prodigy and fails on the same issue as before.
For reference, my venv is through pipenv and Pipfile.

Just to check a few extra things. Are you able to run a Python shell? If so, can you run import spacy or import prodigy from there?

I'm also interested what the python --version and which python commands return. It sounds like there may be a path issue.

Starting a new virtualenv via python3 -m venv venv and running the install commands from there doesn't fix it either?

Thanks again. import spacy works but import prodigy gives the same error as described before. Python version is 3.7.10 and it is in bin/python within the venv.
I have also tried fresh installations a few times, but have not worked either.
Just now I have tried to move the wheel file into my directory and did not work

There are a few ideas in my mind now, but I agree this is a strange situation. My ideas are based on the idea that there's something strange in your virtualenv.

  1. Have you tried making a fresh virtualenv? If there's something amiss with paths in your venv, reinstalling tools in the same venv might not have the effect we want.
  2. Have you tried making a fresh virtualenv with another Python version? Maybe Python 3.8?
  3. Stackoverflow suggests that it might help to either python -m pip install uwsgi within your venv, or to sudo apt-get install libpython3.7 before making a new venv. Have you tried that?