prodigy commands from CLI open #!/bin/sh on windows 10


I tried to run the image-manual recipe, and when I hit enter in the terminal it didn't come back with text about opening a browser to localhost:8080, it wants me to pick a program to open a file, when I choose a web browser (chrome) I get the following:

After that I tried to run prodigy stats, and the same thing happened. I installed from pip using
python -m pip install prodigy -f
and didn't get any errors ( I switched out my license for the XXXX's)

I would guess this is trying to run a linux thing, but I'm on windows 10.

hi @pat02,

Thanks for your question and sorry about the issues. Also sorry for the delay - almost the entire team was an offsite the last few days.

That's definitely a bit weird.

But curious on a few questions:

Have you ever been able to run Prodigy on this Windows machine?

I suspect you can't run prodigy stats (right?) -- if not, can you confirm you what version of Python you're using?

Sorry to ask, but can you provide the exact command you're using? Especially providing additional ones. I've sometimes seen weird things in Windows with its CLI string parsing so it would be good to check other recipes.

Related, can you run any other recipes or is this only with image.manual?

Last, just curious, what if you try to install a different version of Prodigy?

For example, try to run:

python -m pip install prodigy==1.12.7 -f


python -m pip install prodigy==1.11.14 -f

Do either of those versions work?

It installed successfully the first time. I read somewhere that starting CLI commands with "python -m prodigy", instead of "prodigy" could solve it, and it did for me.

How do I mark this closed?


Yes, we have it here in the docs

No need. We mark them internally closed. Thank you!