I keep getting "oops! something went wrong" when i try to run it after installation. Help?

I installed prodigy and it appears on my package when i run pip list, and i followed the instructions on https://prodi.gy/docs/workflow-first-steps. I then ran the anaconda prompt:
-m prodigy dataset new_dataset
-m prodigy ner.teach new_dataset en_core_web_sm news_headlines.jsonl
with sample data but the interface keeps showing me this error message, Oops! Something went wrong! Anyone know what the problem could be?? Thanks in advance!!

Hi! The message in the app is usually shown when Prodigy itself raises an error and stops the server.

If you go back to your terminal, it should show you the error message and more details on what’s wrong – the last few lines are usually the relevant ones.

Hi Ines! Thanks for getting back to me. The problem is that we don’t actually have an error message in the terminal, everything functions well in the terminal and it gives us this message:
" ? Starting the web server at http://localhost:8080
Open the app in your browser and start annotating!"
but when we open the address in the browser we get a page that says “Oops! There was a problem.” So I’m not really sure where exactly the problem is if everything appears to be functioning normally in the terminal. Thoughts?
Thanks so much!

Thanks for the update! Could you open the browser’s developer tools and check if there’s an error message in the console?

Also, you’re not using a secure cloud environment and Internet Explorer by any chance, are you? If so, see this thread for details and a solution – this is a known issue with how IE is configured in secure environments.


I am using mozila. I see a lot of message in mybrowser’s developer tools

TypeError: document.documentElement is null include.preload.js:316:7

Error: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data bundle.js:1:124331

Das Skript von “http://localhost:8080/bundle.js” wurde geladen, obwohl sein MIME-Typ (“text/plain”) kein für JavaScript gültiger MIME-Typ ist.[Weitere Informationen] localhost:8080

Error: SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

This is very strange – I’ve never seen this problem before :thinking:

Could you share the exact details of the browser (version etc.) and operating system? You can use mybrowser.fyi to look this all up automatically. Also, which version of Prodigy are you using?

If anyone comes looking for the answer to this, I ran into the same error and it had to do with the model itself. I had attempted to remove/replace the NER pipe and export the model to a new one and something must have gone sideways with the process.