Cannot see the entity on prodigy UI


I have the enterprise version of prodigy and I was trying my hands at NER. But when I spun up the server, the UI does not show up the word. I tried on different browsers as well: safari and chrome.

Please help.

Atir Petkar

When I select some option though (correct, wrong or pass), the word does comes up in "History" pane. but I cannot see the word at all in the annotation pane.

Hi! I think you might be hitting this:

Check if your prodigy.json contains an "html_template" value and if so, remove it, because it'd otherwise overwrite the template used in the recipe. I've already added a warning for this in the upcoming Prodigy v1.10, so Prodigy will tell you if your config is overwriting something it probably shouldn't.

Hi Ines,

Thank you so much for your quick reply.

So I did had the html_template value in prodigy.json. I removed that but now I face another issue.
So it starts all good and the server starts just fine as shown in the screenshot:

But then when I go to that port in browser, it throws error.

Am sorry, did I miss anything?
Please let me know.

Atir P

It looks like the vectors didn't output anything for the given target vector, at least nothing that's under the given threshold. Maybe try playing with the --threshold and --n-similar settings a bit?

You might also see better results if you focus on either verbs, adjectives or nouns. The context window of the vectors is smaller, wihch means it produces more accurate similarity results for terms used in similar contexts like similar verbs and noun phrases. It's less sensitive to "words from a similar domain" (we tried this too, you get this type of behaviour if you're training with a much larger window, but the similarity results are also going to be less precise and useful this way).

Woohoo, so now it works with reducing threshold to 0.4.

But I was not clear about this term though --n-similar, I kept it at 1 and 100, but what is the difference between the two. I do understand Sense2vec gives the closest terms in vector space for a given word using s2v_most_similar in python, but in prodigy ui, at a time we always get only 1 word at a time while annotating correct?