Unable to run prodigy in Python 3.6.3

Hi Team,

I'm unable to run prodigy. It throws the below error. The module is present in the python lib path. prodigy is the only package unable to find it. Ay help is highly appreciated

werwedp@pefwerwd14:/opt/apps/rwerwe/python36/python36/lib/python3.6/site-packages > /opt/apps/rwerwe/python36/python36/bin/python36 -m prodigy
Traceback (most recent call last):
File "/opt/rh/rh-python36/root/lib64/python3.6/runpy.py", line 183, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File "/opt/rh/rh-python36/root/lib64/python3.6/runpy.py", line 142, in _get_module_details
return _get_module_details(pkg_main_name, error)
File "/opt/rh/rh-python36/root/lib64/python3.6/runpy.py", line 109, in _get_module_details
import(pkg_name)
File "/opt/apps/rwerwe/python36/python36/lib/python3.6/site-packages/prodigy/init.py", line 1, in
from .util import init_package
ImportError: libpython3.6m.so.1.0: cannot open shared object file: No such file or directory

Thank You

Hi! That's strange, I haven't seen this error before :thinking:

I just googled for it and do any of the suggestions in this thread help? https://github.com/JacquesLucke/animation_nodes/issues/906

I had a similar issue and the advice in this link seems to have worked. Specifically running sudo apt-get install libpython3.X (for whatever version is being used).

Hi Guys,

Thanks for your quick response. This is how i fixed the issue.

1 - Initially i was unable execute "python -m prodigy". it was throwing ImportError: libpython3.6m.so.1.0: cannot open shared object file: No such file or directory

2 - That file was available in the installation location but was named as libpython3.6m.so

3 - I created a symlink libpython3.6m.so.1.0 pointing it to libpython3.6m.so

4 - Now i tried to execute "python -m prodigy" but it failed with the same error.

5 - After troubleshooting, i found that i was not enabling the python environment rather i was using full path to use the python3 as we have multiple versions of python installed.

6 - I enabled the environment using this command - scl enable rh-python36 bash. and now I'm able to run prodigy.

I believe this issue is seen in Red Hat environment where multiple python versions are installed using software collections.

Thanks again for your support.

Thank you,
Kishan

1 Like

this lib was already installed on the server. I posted the solution on how i fixed it.

Thank you