The latest prodigy depends on old pydantic and fastapi versions

Hi, prodigy 1.11.9 depends on old fastapi version <0.79.0 and old pydantic version <1.8. These fastapi and pydantic versions conflict with other more recently released python packages. E.g. langflow and chromadb in my particular case.
Do you plan any maintenance release of prodigy to upgrade these dependencies to something more recent?

Hi Ondra,

we're going to be upgrading the dependencies in the next release, but I cannot guarantee versions just yet. The balance here is that we want to be flexible and allow a wide array of versions, but the same time we want to be conservative and make sure newer versions don't break anything.

1 Like

Just reporting back in, we've just released a version with upgraded dependencies. Details can be found here:

1 Like

Thank you very much! I am returning back to annotations and this upgrade of deps is very convenient.