Pyannote recipe unavailable


I am unable to load the pyannote recipe, I have installed pyannote in my prodigy environment an am not sure what I am missing.

(prodigy) ai:~/work/llm-telephony-transcripts/notebooks/001-design$ pip list
Package                       Version
----------------------------- ----------
aiobotocore                   2.2.0
aiofiles                      23.1.0
prodigy                       1.11.13
prompt-toolkit                3.0.39
protobuf                      4.21.12
ptyprocess                    0.7.0
pure-eval                     0.2.2                3.0.0
pyannote.core                 5.0.0
pyannote.database             5.0.1
pyannote.metrics              3.2.1
pyannote.pipeline             3.0.1

I have read a similar post around issues running this recipe, and saw you requested them to run the below, and it states that it can't find the recipe:

(prodigy) ai:~/work/llm-telephony-transcripts/notebooks/001-design$ python -m prodigy pyannote.sad.manual --help 
✘ Can't find recipe or command 'pyannote.sad.manual'.
Run prodigy --help to see available options. If you're using a custom recipe,
provide the path to the Python file using the -F argument.

I also just tried to use --help to list recipes and this is what I see:

(prodigy) ai:~/work/llm-telephony-transcripts/notebooks/001-design$ python -m prodigy --help

============================ ✨  Available recipes ============================

audio.manual, audio.transcribe

stats, drop, db-in, db-out, db-merge, progress, compare, mark, match,
print-dataset, print-stream, review, spacy-config, train, train-curve,



dep.teach, dep.correct


ner.teach, ner.manual, ner.correct, ner.make-gold, ner.silver-to-gold,

pos.teach, pos.correct, pos.make-gold

sent.teach, sent.correct

spans.manual, spans.correct


textcat.teach, textcat.manual, textcat.correct

hi @bev.manz,

Thanks for your message.

Unfortunately, Pyannote is a third party library that has not extended support for the latest versions of Prodigy.

I suspect you're running into this due to a more recent version of Prodigy.

There's a related post:

You could try with an older version of Prodigy -- I'd suggest around v1.11.7. The previous post had tried v1.11.14 and it wasn't working.

You can get any old Prodigy wheel file by using then using your License Key as the Username.

Hope this helps!