prodigy progress ner_news_headlines error in prodigy==1.11.8a4

Using prodigy==1.11.8a4, with config

    "feed_overlap": false,
    "batch_size": 10,
    "experimental_feed": true,
    "instant_submit": true

with command

PRODIGY_ALLOWED_SESSIONS=hao,hao2 PRODIGY_LOGGING=basic prodigy ner.manual ner_news_headlines blank:en ./annotated_news_headlines-ORG-PERSON-LOCATION-ner.jsonl --label PERSON,ORG,PRODUCT,LOCATION

before labelling anything I ran prodigy progress ner_news_headlines:

root@junwang-ec2:/workspaces/multitask-llm-rnd/labelling# prodigy progress ner_news_headlines
✔ Loaded 0 annotations from 1 datasets

=================================== Legend ===================================

New      New annotations collected in interval
Total    Total annotations collected   
Unique   Unique examples (not counting multiple annotations of same example)

============================ Annotation Progress ============================

   New   Unique   Total   Unique
   ---   ------   -----   ------

After label some data I ran the command again but got this error

root@junwang-ec2:/workspaces/multitask-llm-rnd/labelling# prodigy progress ner_news_headlines
✔ Loaded 31 annotations from 1 datasets
Traceback (most recent call last):
  File "/opt/conda/envs/py38/lib/python3.8/", line 194, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/opt/conda/envs/py38/lib/python3.8/", line 87, in _run_code
    exec(code, run_globals)
  File "/opt/conda/envs/py38/lib/python3.8/site-packages/prodigy/", line 61, in <module>
    controller = recipe(*args, use_plac=True)
  File "cython_src/prodigy/core.pyx", line 426, in prodigy.core.recipe.recipe_decorator.recipe_proxy
  File "/opt/conda/envs/py38/lib/python3.8/site-packages/", line 367, in call
    cmd, result = parser.consume(arglist)
  File "/opt/conda/envs/py38/lib/python3.8/site-packages/", line 232, in consume
    return cmd, self.func(*(args + varargs + extraopts), **kwargs)
  File "/opt/conda/envs/py38/lib/python3.8/site-packages/prodigy/recipes/", line 454, in progress
    key, print_key = get_timestamp_key(ts, interval)
  File "/opt/conda/envs/py38/lib/python3.8/site-packages/prodigy/recipes/", line 408, in get_timestamp_key
    year = ts.year
AttributeError: 'float' object has no attribute 'year'

Hi @wjhtomwjh,

You have definitely come across one of the DB-relates issues with the experimental 1.11.8a4 version. To avoid the problem you've experienced, I'd like to recommend upgrading to the latest 1.11.9 release that alleviates the problem of duplicates that 1.11.8a4 was meant to solve. One thing to note, though, is that 1.11.9is a patch on 1.11.8 so it uses the same DB setup. Please, check 1.11.9 release post for more details.