NER.manual Labels not changing

I had some trouble getting Prodigy working with my JupyterLab and in the end I just tried every solution on the web repeatedly until it eventually it "works" ( I say works in inverted commas as the trouble installing it makes me anxious and no idea what got it going).

I then ran the NER fully manual annotation example with the news headlines download

ie !python -m prodigy ner.manual ner_news_headlines blank:en ./news_headlines.jsonl --label PERSON,ORG,PRODUCT,LOCATION

This worked . I was happy and a little surprised given how yucky the install was. :grinning:

I then made my own jsonl with animals in sentences then changed the labels :dog2: :cat2: :fox_face:

When I run it the text appears but the labels are still the PERSON, ORG, PRODUCT, LOCATION of the example.

!python -m prodigy ner.manual ner_animal_data blank:en ./animal.jsonl --label CAT,DOG,FOX

This made me sad. :smiling_face_with_tear:

What am I doing wrong? Was the install so traumatic prodigy has gone wrong and if so how do I check its "mental" health. :brain: :face_vomiting:


Dave of the jilted generation

Welcome to the forum @HAL9000 :wave:

Sorry to hear you had troubles installing Prodigy! I wonder what the issue was, because I just had to do the fresh installation to check your issue and it worked almost seamlessly. I do admit that our docs instruct to use a deprecated way of installing a jupyter plugin that will lead to an error. The error message does say that you should use pip instead.
Let me just recount the steps in case someone else stumbles upon a similar issue

So in a fresh virtual env:

python -m pip install jupyterlab
python -m pip install python -m pip install jupyterlab-prodigy

with these steps you should be able to run Prodigy in jupyter.

Back to your question, by labels are the same you mean that PERSON,ORG,PRODUCT,LOCATION appear in the UI?
Not really sure why you could possible see such behavior. Could you re-run your command with a fresh target dataset!python -m prodigy ner.manual ner_animal_data_test blank:en ./animal.jsonl --label CAT,DOG,FOX command and send me a screenshot similar to this one:

Also, the first example in in your animal.jsonl - thank you!

Thanks Magda.. Will give it a try and get back to you. I did follow the docs so it is nice to know that the error is there.

Hi Magda. Uninstalled to clean and then followed your suggestion. Works fine now. I think you this can now be closed as solved. Thanks Dave

1 Like

Glad to hear that! Thanks for reporting back :slight_smile: