Not a supported wheel on this platform

I have been provided a link to download wheels to install Prodigy. However my macbook has macOS 10.12.6 and it seems Prodigy requires min. 10.13 for macOS?

ERROR: prodigy-1.9.6-cp36.cp37.cp38-cp36m.cp37m.cp38-macosx_10_13_x86_64.whl is not a supported wheel on this platform.

Hi! Have you tried renaming the wheel to match your platform? See the installation docs for details:

pip cares about the name of the file and needs it to match your system. The exact macOS version shouldn't matter ā€“ the default name just indicates the one the wheel was packaged with.

Thanks Ines! It is successfully installed now.

1 Like


I keep getting this same error, saying that it is not a supported wheel on this platform. However, I have gone through these steps and have updated my filename to match my platform and it still does not work. Is there something else I could be doing wrong?

Thank you in advance for any help you can provide!

What's your operating system, and which filename did you end up with? Also, maybe the following pip issue is relevant:

Hi Ines! Thank you for your response.

My operating system is macOs Catalina 10.15.3.

The file name that I ended up with was prodigy-1.9.6-cp36.cp37.cp38-cp36m.cp37m.cp38-macosx_10.15-x86_64.whl -- I found that my platform was macosx-10.15-x86_64.

Do you think there is something incorrect with this?

Thank you very much in advance for your help!

Also, I have looked at the link you recommended (... is not a supported wheel on this platform) and have changed the filename from cp38-macosx_10.15-x86_64.whl to cp38m-macosx_10.15-x86_64.whl and it still does not work.

My pip version is pip 20.0.2. My python version is Python 3.8.1.

What happens when you replace the - with a _ here, i.e. 10.15_x86_64? The filename is used to determine the package, compatibility etc., so pip is very strict about it and it needs to match 100%.

Hi Ines!

Thank you for your response.

Unfortunately, with the replace of ' - ' to '_', it still says that the it is not a supported wheel on this platform.

I am not sure what to do. This is a paid package as well.

Thank you for your continued assistance.

Ah, I just noticed I missed the . ā€“ all hyphens and periods need to be _, just like in the original filename.

A wheel file is really only a glorified ZIP file that can be read and unpacked by pip, so you can always just unzip it and copy the files into your site-packages, your working directory or wherever else you want to put it. In that case, you'd just need to install the dependencies yourself.

Hi Ines!

Thank you for your message.

Hm, I have also changed the . to _ and I still get the same error.

Is there anything else that could be wrong with my computer, system, etc? Does it matter if I am installing this in a virtualenv?

I am very sorry for this! I greatly appreciate your help, Ines! Thank you!

Sorry this has been so frustrating :disappointed: It's really unlikely that there's something fundamentally wrong with your system ā€“ it pretty much always comes down to pip and whether it likes the file name (and this can differ depending on the pip version, which is why the m thing occurs).

I just checked and I run macOs 10.15 as well, and interestingly, I can install the default wheel without problems and without having to rename it (venv with Python 3.7.2 and pip 18.1).

To make sure I can try and reproduce your state: What file name did you end up with, and which Python version are you running in your virtual env?

Hi Ines,

Thank you for your continued help.

The initial file name is: prodigy-1.9.6-cp36.cp37.cp38-cp36m.cp37m.cp38-macosx_10_13_x86_64.whl

With your above recommendations, the file name becomes: prodigy-1.9.6-cp36.cp37.cp38-cp36m.cp37m.cp38m-macosx_10_15_x86_64.whl

However, whenever I am testing it, I use both the above file name, as well as: prodigy-1.9.6-cp36.cp37.cp38-cp36m.cp37m.cp38-macosx_10_15_x86_64.whl (omitting the 'm' after the cp38.

The python version is Python 3.8.1.

Thank you very much!

Thanks! I just set up a test environment with the same Python version, same pip version, same OS version. The following file name (the initial file name we distribute) worked as expected for me with pip install:


10_13 vs. 10_15 doesn't make a difference for me, but I can confirm that it doesn't work if I make it cp38m.

This might be a stupid suggestion, but did you double-check that the file you're pointing pip install to actually exists at that location? Because the error pip shows if the file doesn't exist looks very similar. Maybe try pip install *.whl (with whichever relative path) to make sure the file name doesn't get messed up on the command line?

Hi Ines!

Sorry for my late response due to the Holiday weekend!

Wow, great suggestion on using *.whl. This worked! I am not sure what happened as I was very careful to copy over the correct name, but perhaps there was something else that was missing or something else! But, regardless, everything is now installed correctly. Thank you very much for your great suggestion! I greatly appreciate your help!

1 Like