tried on won 10 centos both said .whl is not a supported wheel on this platform.

tried on won 10 centos both said .whl is not a supported wheel on this platform. python 3,5,4 on bothdo we need 3.6?

I think this is due to Python wheels being quite tricky. We currently build wheels on machines running macOS 10.13, Ubuntu 17.04 and Windows 10. Based on the wheel’s exact file names, pip decides whether it’s supported or not. The good news is, you can usually rename the files to make them work.

As an experiment, could you run the following:

python -c "import distutils.util; print(distutils.util.get_platform())"

And then rename your wheel and replace the part I highlighted with the output of the above command:

prodigy-0.5.0-cp35.cp36-cp35m.cp36m-[YOUR PLATFORM HERE].whl

If this doesn’t work, you can always just unzip the wheel file (a .whl file is essentially just an archive) and install it manually, or move it somewhere and execute Prodigy from there.

(Btw, also in case others come across this issue later: I’ve found this guide very helpful to understand how wheels work and what’s going on here).


Done windows 10 could not install centos python 3.5 doing thanks

in my windows it was amd-64-3.5 so it did not take its okay me successful in centos

Are the wheels built only for windows 32? I tried renaming it from prodigy-1.0.0-cp35.cp36-cp35m.cp36m-win32.whl to prodigy-1.0.0-cp35.cp36-cp35m.cp36m-win_x86_64.whl but still got the same error with python 3.5 and 3.6

I also tried making a custom environment with

conda create -n py36_32 python=3.6

but this then makes it very difficult to find a version of spacy on conda-forge since they are all compiled for win64


win64 python 3.5

python -c "import pip; print(pip.pep425tags.get_supported())"

[('cp35', 'cp35m', 'win_amd64'), ('cp35', 'none', 'win_amd64'), ('py3', 'none', 'win_amd64'), ('cp35', 'none', 'any'), ('cp3', 'none', 'any'), ('py35', 'none', 'any'), ('py3', 'none', 'any'), ('py34', 'none', 'any'), ('py33', 'none', 'any'), ('py32', 'none', 'any'), ('py31', 'none', 'any'), ('py30', 'none', 'any')]

win32 python 3.6

python -c "import pip; print(pip.pep425tags.get_supported())"

[('cp36', 'cp36m', 'win32'), ('cp36', 'none', 'win32'), ('py3', 'none', 'win32'), ('cp36', 'none', 'any'), ('cp3', 'none', 'any'), ('py36', 'none', 'any'), ('py3', 'none', 'any'), ('py35', 'none', 'any'), ('py34', 'none', 'any'), ('py33', 'none', 'any'), ('py32', 'none', 'any'), ('py31', 'none', 'any'), ('py30', 'none', 'any')]

@kmader Hmm! It looks like we built the wrong wheels. We’ll fix this and get the Windows 64 wheels up, probably tomorrow. Thanks!

In the meantime, you could work around the spaCy problem by doing a source install, instead of installing via conda wheel. You can do this with pip install spacy.

@kmader We just updated the Windows wheel, so you should be able to update the new one (win64, Python 3.5/3.6) via your download link. See my comment here for more info.

1 Like