I am trying to install for the first time using the whl file.
Python 3.10.12

I get error ModuleNotFoundError: No module named 'prodigy._util'

what should I do?

hi @sb1000,

Thanks for your question and welcome to the Prodigy community :wave:

Sorry you're having issues.

A few questions:

When do you get this error?

Are you trying to import it in a Python script (e.g., writing a custom recipe)?

Related, are you able to run prodigy stats? If so, can you provide those details?

Thank you for the welcome, yes I was importing and writing a custom recipe.

I get this error:
python -m prodigy stats
Traceback (most recent call last):
File "lib\", line 187, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File "lib\", line 146, in _get_module_details
return _get_module_details(pkg_main_name, error)
File "lib\", line 110, in get_module_details
File "lib\site-packages\prodigy_init
.py", line 1, in
from ._util import init_package
ModuleNotFoundError: No module named 'prodigy._util'

More details:
I am using conda:
I created a new environment just for prodigy
I installed via .whl file

I tried new environments and different installs and still get same error.

Thanks for the details. Yes, this seems like there was a problem with the installation.

We've seen this previously due to incompatible Python versions, especially with conda.

I know you tried, but can you double check you're using the consistent Python version (e.g., try which python or which python3) to ensure you're installing Prodigy with a wheel consistent with the Python version you're running?

Just curious, can you also try to install Prodigy viapypi, not a wheel file?

thank you for responding.

It is not possible to install via pypi due to the proxy.

I have tried multiple versions all in new miniconda environments.:
python 3.11 - prodigy-1.12.7-cp311-cp311-win_amd64
python 3.10 - prodigy-1.12.7-cp310-cp310-win_amd64

All receive that same error

ModuleNotFoundError: No module named 'prodigy._util'

I can run - pip install prodigy-utils

This does not fix the issue still the same error

I also tried copy and pasting the extracted zip file across as suggested in another post and this still does not work

hi @sb1000,

Thanks for the details and sorry you're having issues.

Ah - I suspect this is the problem. Whether you install with the wheel file or via pypi, by default, it'll try to install dependencies automatically, trying to install them via pypi. Since you're behind a proxy, any of those packages that aren't part of your miniconda, likely won't be installed correctly. I suspect if you went through your logs when you try to install, you may find some of your dependencies aren't correctly installed.

Can you try to follow these instructions (see instructions on installing w/o the internet), installing each dependency first, then installing your wheel file with --no-deps?

Thank you again.

Unfortunately I still get the error even after I tried that method and all the other dependencies do not have errors when being loaded.

I am all out of ideas, as not sure what the issue is.

Hi @sb1000-

I sent you a follow up email. Hopefully we can resolve your issue from there.