Can I do annotation for BERT on prodigy

Can I do annotation and convert to BERT on prodigy

hi @Mohammad,

Yes. Please see our documentation on using Prodigy for BERT.

There are also many posts with the transformers tag that may help as well.

I got this error below when I tried this commend :slight_smile:

Can't find recipe or command 'bert.ner.manual'

python3 -m prodigy bert.ner.manual correctd_drsv1 ./model_drsv1 ./CV_json_English_Format.jsonl --label Skill
,University,Designation,Degree,Experience --patterns patternsv1.jsonl ./bert-base-uncased-vocab.txt --lowercase --hide-wp-prefix -F

That means you're having a lookup error.

Is the script in the same folder where you ran that command?

yes also the commend below give me the same error

python3 -m prodigy bert.ner.manual --help

Yes, you would because you haven't correctly referenced your script.

How can Prodigy get help information about bert.ner.manual when it hasn't been pointed to where the script is?

Again, your problem is you're not pointing to the correct path for your script. Try putting the absolute path directory to where you have saved your, e.g., -F ~/Downloads/my_folder/

now I get this error
usage: prodigy bert.ner.manual [-h] [-lo None] [-l None] [-tv None] [-LC] [-HS] [-HW] dataset source
prodigy bert.ner.manual: error: unrecognized arguments: ./bert-base-uncased-vocab.txt

python3 -m prodigy bert.ner.manual BERT_drsv1 ./CV_json_English_Format.jsonl --label Skill,MaritalStatus,University,Designation,Degree,Experience ./bert-base-uncased-vocab.txt --lowercase --hide-wp-prefix -F

hi @Mohammad!

Yes, that looks because you don't have the bert-base-uncased-vocab.txt. Save it from the link I provided and make sure your path reference is correct.

Thanks it working now