Unless im mistaken, publishing a trf model to Hugginface is broken.

I have tried multiple times but even the spacy inference API doesn't work for: spacy/en_core_web_trf · Hugging Face. All it does is throw an error. issubclass() arg 1 must be a class which then means I can't clone the workspace. It's basically just a repository to store the whl currently. Is this expected? The small model you publish works but even the spacy trf model throws the same error.

Hi @Netizine,

No, you're not mistaken. I can confirm it's, indeed, broken. It's likely related to incorrect environment in which the inference widget is run, which I'm not 100% sure yet but I don't think we have direct control over - looking into it.

Thanks. I went aroud in circles wondering what i was doing wrong until i saw the spacy trf model had the same issue.

Hey @Netizine , just an update that it looks like some parts of the community api project need update to pydantic v2. Hopefully it can be done soon but can't give any estimate at the moment.