process_response error when serving Prodigy

Hi,

Installed “prodigy-1.5.1-cp35.cp36-cp35m.cp36m-linux_x86_64.whl” on ubuntu 18.04.

When I am trying to invoke prodigy url to annotate, facing the below error.
Internal Server Error

Traceback (most recent call last):
File “/home/ramesh/anaconda3/envs/nlp/lib/python3.6/site-packages/waitress/channel.py”, line 356, in service
task.service()
File “/home/ramesh/anaconda3/envs/nlp/lib/python3.6/site-packages/waitress/task.py”, line 176, in service
self.execute()
File “/home/ramesh/anaconda3/envs/nlp/lib/python3.6/site-packages/waitress/task.py”, line 447, in execute
app_iter = self.channel.server.application(env, start_response)
File “/home/ramesh/anaconda3/envs/nlp/lib/python3.6/site-packages/hug/api.py”, line 491, in api_auto_instantiate
return module.hug_wsgi(*args, **kwargs)
File “falcon/api.py”, line 289, in falcon.api.API.call
File “falcon/api.py”, line 286, in falcon.api.API.call
TypeError: process_response() takes 4 positional arguments but 5 were given

(generated by waitress)


Installed packages and version:

falcon (2.0.0)
hug (2.5.1)
hug-middleware-cors (1.0.0)
spacy (2.0.13)
thinc (6.10.3)
waitress (1.3.0)

Please advise.

Thanks,
ramesh.

2 Likes

Never mind.

This is working for me by changing versions as
falcon==1.4.1
hug==2.4.1
thinc==6.10.3
spacy==2.0.12
prodigy==1.5.1

Thanks,
ramesh.

3 Likes

Thanks for updating with your solution! I think this might be related to an update to Hug or conflicting dependency versions. I’ll have a look to see if there’s anything we need to pin more strictly / explicitly for the next release.

RAMESH THANK YOU SO MUCH! We were banging our heads against the wall the past day wondering why suddenly things stopped working.

2 Likes