Problem with spacy emoji and the force= true

spacy
off-topic
(Gilberto Flores Pochet) #1

Hi Ines,

I am having the problem of this forum https://github.com/mpuig/spacy-lookup/issues/3, but for spacy Emojis(https://github.com/ines/spacymoji):

ValueError: [E090] Extension ‘has_emoji’ already exists on Doc. To overwrite the existing extension, set force=True on Doc.set_extension.

It is any easy fix for this problem?

Thanks a lot for the help,

Gilberto

0 Likes

(Gilberto Flores Pochet) #2

Hi Ines,

I created a fork project with the quick solution, maybe you can put the solution in the original project?

Best,

Gilberto

0 Likes