Model en_pipeline is incompatible with current version

While doing some annotations using rel.manual I started to see this message come up after annotating about 10 documents.

UserWarning: [W095] Model 'en_pipeline' (0.0.0) requires spaCy >=3.0.3,<3.1.0 and is incompatible with the current version (3.0.0rc5). This may lead to unexpected results or runtime errors. To resolve this, download a newer compatible model or retrain your custom model with the current spaCy version. For more details and available updates, run: python -m spacy validate

I'm annotating with a custom NER model trained in Spacy3, I reinstalled Spacy and retrained the NER model but the message still persists.

Hi! It looks like you're still running the nightly pre-release version of spaCy (3.0.0rc5) in your environment? Check if you have spacy-nightly installed, that might be shadowing the stable spacy.

1 Like

Ha! That was it, thanks!

1 Like