exclude not working on ner.correct

The --exclude command is not working and I keep seeing the same text that I have already annotated.
prodigy ner.correct ner_arrendamiento_v2 modelo_v1/model-best /home/diego/Descargas/funcion/datos_entrenamiento_arrendamiento/roles_arrendamiento_v1.jsonl --label arrendatario,arrendador,fiador,obligado_solidario,habitante,rep_arrendador,rep_arrendatario,rep_fiador,rep_obligado_solidario --exclude ner_arrendamiento_v1

This command do not exclude the dataset ner_arrendamiento_v1

must be related to Duplicate annotations in output - #5 by marc

1 Like

Thanks for the report on this. I've been trying to work out why this is happening but I've been totally unable to reproduce. We've heard some other reports that --exclude has been failing to work.

Would either of you be comfortable sharing a minimal example where you're seeing the --exclude parameter not working? I can share my email so we can keep any data private and off the forum.

prodigy ner.correct ner_arrendamiento_v2 modelo_v1/model-best /home/diego/Descargas/funcion/datos_entrenamiento_arrendamiento/roles_arrendamiento_v1.jsonl --label arrendatario,arrendador,fiador,obligado_solidario,habitante,rep_arrendador,rep_arrendatario,rep_fiador,rep_obligado_solidario --exclude ner_arrendamiento_v1