When running ner.manual recipe, server never starts and source data just keeps printing to console

I'm using the example ner.manual recipe from the prodigy docs but whenever I run it, I just get a stream of the source file to the console:
CleanShot 2022-11-06 at 03.26.02

Here is the command I'm entering:

prodigy ner.manual java_ner blank:en ./third_parties.jsonl --label THIRDPARTY --patterns ./rules.jsonl -C

This happens a lot and I'm not sure what's causing it. Previously, I thought it was being caused by some code in a custom recipe I was trying, so I tried one of the built in recipes and it does the same thing.

I've been able to annotate successfully, but this seems to happen at random (I'm sure it's not, I just can't pinpoint the cause).

Any ideas?

Update: when I removed the --patterns ./rules.jsonl from the command it worked normally but obviously not utilizing the patterns file.

Update 2: Tried this custom recipe from the recipes repo with the same data as my original post and the console printing is happening again.

Terminal command I'm using (tried excluding patterns here to see if it helped again but no luck):

prodigy ner.teach-java  java_ner_teach en_core_web_sm /Users/ben/code/prodigy-env/third_parties.jsonl  --label "Label1,Label2" -F ./new-java-recipe.py

Interesting. Is there anything special about your rules.jsonl file? How large is it? Does it contain patterns for the label of interest?

I threw the GIF into a video app and it seems to show Java code? Can you confirm that this is one of the examples that you're working on?

If so, it seems like there are lots of duplicates in there. Is that accurate?

yes, you've got the data right, it's Java code snippets. I haven't de-duped the data yet, just trying to get Prodigy running. rules.jsonl content below. I eventually just tried the example in the docs because I couldn't get anything working and I figured it was worth a shot to just copy paste the example.

{"label": "ORG", "pattern": "Apple"}
{"label": "GPE", "pattern": [{"LOWER": "san"}, {"LOWER": "francisco"}]}

Could you share an example from your training data as well? It doesn't have to be an exact copy of the data, as long as it's an example that triggers the same issue so that I might be able to reproduce locally.

My current gut feeling is that you may be running a patterns file with labels that you aren't listing in --label.