UnicodeDecodeError in plotext library

Im not sure if I can just follow up on this topic since its labelled as solved or maybe start a new one.

I will ask here for now and transfere it if need be.

I have a technical follow up question to the one above.
I run train-curve and I get these results:

I understand that I can not see the plot because that was an extended application. But I am getting the following error after the output.

Hi! I moved this post to a new thread since it's pretty specific to one of the newer features added to the train-curve command. It looks like the error happens within the plotext library, which is a third-party dependency we don't control.

One explanation could be that it can't handle the encoding in your Jupyter environment, so as a workaround, you could try and run the command in your regular terminal?

You could also try and run any of the other examples from the plotext docs in your notebook and see if you see the same error: GitHub - piccolomo/plotext: plotting on terminal If so, it might be a problem with the library and you could open an issue on their tracker.

Yes right,

I will try that now and update for people who will face the same challenge in the future. :grinning: :grinning: