Support for spaCy v2.1

We’re hoping to have the release ready by the end of this week! If you want to test the beta wheels before that, feel free to send us an email.

As Matt mentioned above, the new spaCy version is very new and backwards-incompatible with the previous version when it comes to the models and matcher engine (both important features for Prodigy). We wanted to get spaCy v2.1 out as early as possible to give users enough time to make sure they’re able to upgrade their applications, before also asking all our Prodigy users to retrain all of their models. I also just shared some more background here:

1 Like

Btw, quick update in case you missed it: We released v1.8 yesterday, which introduces support for spaCy v2.1, including a bunch of other new features. See here for the full release notes: https://prodi.gy/docs/changelog