saved model doesn't work after saving or updating the model to local area

Hi, I have tried to train a tagger which based on ‘en’ model.

It seems works fine like below when it just finished training from given data.

But, the thing is whenever trying to load that saved model from that PATH, it doesn’t work. I mean, it loaded but, tagger seems has no improvement although I saw tagger improvement on the test just before saving the model.

like this:

same test sentence has a different result on different python file.
Can you explain what happens here and the meaning of saving the model is?

Hi,

The part-of-speech tagging recipes are still quite new, so I apologise if there are bugs. I’m not sure I understand the issue though. I can’t see the differences in the outputs you’ve provided, and the sentences are different.

Could you show the tags as you print them in your script, and then the tagging made after reloading?

Ok, not a problem

in above, tried to upload the pre-trained model in other python code.
(which called tagger_train.py)

the result is here: “Enter username and password”

  1. when I tried to using trained_model within tagger_train.py
    –> ‘enter username and password’, {‘pos’: ‘VERB’, ‘NOUN’, ‘CONJ’, ‘NOUN’}

  2. using trained_model within other python code
    –> ‘enter username and password’, {‘pos’: ‘VERB’, ‘NOUN’, ‘CONJ’, ‘VERB’}
    –> this result does not seem any changes with basic model ‘en’

Do you see the same mismatch if you use the full sentence, i.e. “enter username and password and click on login”? From your screenshot, it looks like this was the sentence you tried after training the model, and depending on the training data etc., it’s definitely possible that this would produce a different result compared to only “enter username and password”.

Oh that’s good point but, unfortunately there’s no exact sentence like ‘enter username and password’ within the training data. i can see few of a similar sentence structure with above within training data though. Thank you anyway!!