Prodigy disregards db setup

in my prodigy.json I have

"batch_size": 5,
"hide_meta": true,
"choice_auto_accept": true,
"db_settings": {

     "postgresql": {
     "database": "a_db_name",
     "port": 5432,


While other settings are being read from the file
I see from logs that the server connects to:
22:39:22 - DB: Initialising database SQLite
22:39:22 - DB: Connecting to database SQLite

It looks like you’re missing the "db" setting that tells Prodigy the ID for the database type to use, e.g. "db": "postgresql". See here for details.

The "db_settings" is an object that can store multiple credentials for the built-in or custom databases, so the "db" setting lets you specify which one to connect to. If it’s not set, it defaults to SQLite, which I guess is what happens here.

Thanks! That’s probably the case

1 Like