Output model in Prodigy Nightly

Hi, I have been having some problems outputting my trained data to a temporary database. When I run the following command:

prodigy train --ner dow30_data output_dir --./tmp_dow30_model

I receive this in return:

:information_source: Using CPU

========================= Generating Prodigy config =========================
:information_source: Auto-generating config with spaCy
:heavy_check_mark: Generated training config

=========================== Initializing pipeline ===========================
✘ Error parsing config overrides
-> /tmp_dow30_model not a section value that can be overwritten

How can I fix this?

Hi! The output directory is the first argument of the command, so you'd do something like:

prodigy train ./tmp_dow30_model --ner dow30_data

(Adding the -- usually prefixes an argument, so in your example, you were basically defining a command line flag --./tmp_dow30_model. This isn't an known argument, so it's treated as a config override for spaCy.)

Oh thanks for the response, I tried experimenting around with the recipe and ran that as well but get the same/different error:

============================= Training pipeline =============================
Components: ner
Merging training and evaluation data for 1 components

  • [ner] Training: 27 | Evaluation: 6 (20% split)
    Training: 26 | Evaluation: 6
    Labels: ner (17)
    :information_source: Pipeline: ['tok2vec', 'ner']
    :information_source: Initial learn rate: 0.001

0 0 0.00 54.56 0.00 0.00 0.00 0.00
:warning: Aborting and saving the final best model. Encountered exception:
FileNotFoundError(2, 'No such file or directory')

FileNotFoundError: [Errno 2] No such file or directory: 'tmp_dow30_model/model-last'

I got the same error, I just went ahead and made the directory manually and the training started.

Oh yes thank you that worked.

Thanks for the update! It looks like we don't currently create the output directories if they don't exist (at least not with the way we're calling into spaCy from Prodigy), so I'll add that :+1:

1 Like