no task available - ner.manual

11-002_Cleaned.jsonl (12.3 KB)

When I run through assigning a dataset for annotations and run the ner.manual, it shows as no task available even though I have not done anything. I have tried all the troubleshooting tips I could find. I am getting burned out.

Please help.

Here is the example of bash scripts I am implementing.

$ prodigy db-in product_specs file_name
:heavy_check_mark: Created dataset 'product_specs' in database SQLite
:heavy_check_mark: Imported 185 annotated examples and saved them to
'product_specs' (session 2023-11-06_16-56-20) in database SQLite
Found and keeping existing "answer" in 0 examples

prodigy ner.manual product_specs blank:en file_name --label frllabels.txt
Using 16 label(s) from frllabels.txt

:sparkles: Starting the web server at http://localhost:8080 ...
Open the app in your browser and start annotating!


hi @Rossholdin,

Thanks for your message and welcome to the Prodigy community :wave:

You don't need the db-in step. If you're annotating the first time, you don't need to put those records into a dataset and then point directly to the same dataset. Prodigy's deduplication is kicking in because it sees that those records are already in your same dataset.

To get it started:

First, drop your dataset (you need to have a clean one):

prodigy drop product_specs

Then run your command:

prodigy ner.manual product_specs blank:en file_name --label frllabels.txt

Notice no need for db-in.

Does this make sense? I can explain more.

You may also want to know about using dataset: as a source too (see docs).

Also, Prodigy logging too can be helpful as you'd see the deduplication.

Hope this helps!

1 Like

That worked, I think I misunderstood the directions. I appreciate the help!