ner.eval-ab doesn't show results of the a/b test

I ran a ner.eval-ab recipe using two different models. I completed the task but I'm confused now about where I should look for results. I saved the data set but nothing was showed/printed out after the task has been completed - neither in the terminal nor in the prodigy interface. I'm new to the tool so I'm pretty sure I'm missing something obvious, so apologies in advance.

Ah, that's very strange! After you exit the server, the results should be printed in the terminal. How did you exit the process? Did you press ctrl+c or did you do it some other way?

The good news is, the recipe pulls the whole dataset from the database to print the stats on exit (including previously collected examples), so you can always try again, start the server, exit immediately and see the stats. So could you try again, start the server, press ctrl+c to exit and see if you're getting results now?

Started the server again and exited - this time it worked! Thanks!

1 Like