Issue with installing Prodigy 1.11.8a4

I am installing Prodigy with the command:

pip install prodigy==1.11.8a4 --extra-index-url https://{my license key}

and getting the following error:

Looking in indexes:, https://****

WARNING: Skipping page https://**** because the GET request got Content-Type: application/json. The only supported Content-Types are application/vnd.pypi.simple.v1+json, application/vnd.pypi.simple.v1+html, and text/html

ERROR: Could not find a version that satisfies the requirement prodigy==1.11.8a4 (from versions: none)

ERROR: No matching distribution found for prodigy==1.11.8a4

This installation is being done on Ubuntu with Python 3.8.14 and pip version 22.2.2. Installing v1.11.8 actually works on this machine but the alpha version throws this error.

The installation for 1.11.8a4 also works on my macOS system. I am not able to figure out the issue and need some assistance. Thanks

To anybody reading this in the future: I recommend updating pip before installing anything with it.

python -m pip install --upgrade pip

You're already on the most recent version of pip (22.2.2) but I figured mentioning it couldn't hurt for other users.


I tried reproducing your issue on my PopOS machine (it's like Ubuntu, just a bit different), and it seemed to have worked just fine. I was running it with Python 3.8.6, pip 22.2.2.

python -m pip install prodigy==1.11.8a4 --extra-index-url

This is making me wonder if it might be the Python version. It feels unlikely, but it might be worth double-checking. What version of Python are you running on your MacOS system?

Hey @koaning upon further investigation I found out that this was because of a typo in the license key. Because of the ambiguity of the error message it was throwing me off into looking into other possible reasons. Anyways this now resolved. Thanks for the help

1 Like

No worries. Happy to hear it got fixed.

Happy labelling!