install scispacy


I want to run scispacy, but I run into a set of problems. I have created a venv scispacy-env that runs python3.8 (I normally run python 3.6 but one way or another it has upgraded it to python 3.8). In this venv I run the following

pip3 install scispacy

Installing collected packages: scispacy
Successfully installed scispacy-0.4.0
(scispacy-env) XXX$ :~/Venvs/scispacy-env/lib/python3.8/site-packages$

I then start notebook (still in the scispacy-env)

(scispacy-env) XXX$ jupyter notebook

I then try to import scispacy and spacy, wiwth this result

or, I'm stuck. Anyone a suggestion where I made the error, and (especially) how to fix it?



Hi all,

I managed to solve the problem; it was a incompatible version issue, and I reverted back to scispacy==0.3.0

Consider it solved

Glad you got it working! :+1: In general, th spaCy discussions forum or the scispaCy tracker is probably a better place for questions lik this – we're trying to keep this forum very focused on Prodigy.