--exclude in textcat teach is not working as expected.

I have one dataset which is partially annotated. (700 of 1000 were already annotated)
I wanted to resume the annotation thus, I tried to use the --exclude parameter on the same dataset but oddly it is not working and I am still getting some tuples that I had already annotated.

I tried to reproduce the same and created a sample dataset of 4 dummy rows.

Please dont mind the content of this file.
I started the annotation with prodigy teach command,

Annotated two of those tuples, saved the results, and terminated the execution.

later I restarted the labeling with the "teach" method using the same method and the tool again asked me to label already annotated data and now I have annotated a total of 6 tuples.

Am I missing anything here? I went through another topic that suggested the use of --exclude for the same reason.
Please help.

Hi! The annotations in the current dataset are excluded by default, so you shouldn't have to use --exclude with the name of the current dataset. By default, textcat.teach will skip all examples that were already annotated in the same dataset with the same label – so you may see a text again, but with a different suggestion.

If you're seeing the exact same examples again, can you double-check if you're using the latest version of Prodigy and upgrade if possible (or try setting "feed_overlap": false in your prodigy.json).

Ohh. Ok. I will try these options.