error while training a new entity type ner.teach

I tried the commands to train a new entity type in Prodigy on the trial VM provided.

All commands worked fine except the below one,

prodigy ner.teach drug_ner en_core_web_md train --loader Reddit --label DRUG --patterns drugs_patterns1.jsonl

The error thrown is,

Using 1 labels: DRUG
Traceback (most recent call last):
File "/usr/lib/python3.6/", line 193, in _run_module_as_main
"main", mod_spec)
File "/usr/lib/python3.6/", line 85, in _run_code
exec(code, run_globals)
File "/home/prodigy/pgy-env/lib/python3.6/site-packages/prodigy/", line 380, in
controller = recipe(args, use_plac=True)
File "cython_src/prodigy/core.pyx", line 212, in prodigy.core.recipe.recipe_decorator.recipe_proxy
File "/home/prodigy/pgy-env/lib/python3.6/site-packages/", line 328, in call
cmd, result = parser.consume(arglist)
File "/home/prodigy/pgy-env/lib/python3.6/site-packages/", line 207, in consume
return cmd, self.func(
(args + varargs + extraopts), **kwargs)
File "/home/prodigy/pgy-env/lib/python3.6/site-packages/prodigy/recipes/", line 117, in teach
source, api=api, loader=loader, rehash=True, dedup=True, input_key="text"
File "cython_src/prodigy/components/loaders.pyx", line 65, in prodigy.components.loaders.get_stream
File "cython_src/prodigy/components/loaders.pyx", line 252, in prodigy.components.loaders.Reddit.init
OSError: Can't find file path: train

Could anyone please guide ?

Hi! The argument after the model name is the text source you want to load in and annotate. In the tutorial video, we've used a directory called train containing the Reddit data. From the error, it looks like you're trying to load data from a path train, but that path doesn't exist.

I've explained this in more detail here: