Error training with a model

With the last prodigy version when I try to train with a model this error appears

` prodigy train temp_folder --textcat books --base-model en_core_web_lg

I get this result

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/", line 193, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/local/lib/python3.6/", line 85, in _run_code
    exec(code, run_globals)
  File "/usr/local/lib/python3.6/site-packages/prodigy/", line 61, in <module>
    controller = recipe(*args, use_plac=True)
  File "cython_src/prodigy/core.pyx", line 325, in prodigy.core.recipe.recipe_decorator.recipe_proxy
  File "/usr/local/lib/python3.6/site-packages/", line 367, in call
    cmd, result = parser.consume(arglist)
  File "/usr/local/lib/python3.6/site-packages/", line 232, in consume
    return cmd, self.func(*(args + varargs + extraopts), **kwargs)
  File "/usr/local/lib/python3.6/site-packages/prodigy/recipes/", line 282, in train
  File "/usr/local/lib/python3.6/site-packages/prodigy/recipes/", line 171, in _train
    original_logger = config["training"]["logger"]
KeyError: 'logger'

I tested different models with the same result

Hi! This should be fixed in v1.11.1, which was just released :slightly_smiling_face:

Also see this thread for background:

@ines Looks working for 1.11.1 for regular models but when I try to use a trf model show this error

⚠ Aborting and saving the final best model. Encountered exception:
TypeError("'FullTransformerBatch' object is not iterable",)

The command is this

 prodigy train tmp_model --textcat mydb -m en_core_web_trf -L --verbose

Can you check which version of spacy-transformers you have installed and upgrade if it's not up-to-date? It sounds like you're hitting this problem, which should be fixed in a newer release: TypeError: 'FullTransformerBatch' object is not iterable · Discussion #8104 · explosion/spaCy · GitHub

I have the last spacy version, so I will have to wait for the fix, thx

I also had this problem, even with spacy-transformers 1.0.4. Solved it by some users suggestion in the nightly thread to add a few lines to of spacy-transformers.

Hi @TomR and @brobles, can you both confirm that you have the latest version of spacy AND of spacy-transformers? I believe the fix had to be made across both libraries, so it's crucial they're both up-to-date, and not just one of the two.

@TomR: which thread & fix is that?

I definitely want to look into this if a similar error is still present!

Hi all, and thanks for your patience.
I was able to reproduce this, and it should now be fixed after upgrading to spacy-transformers 1.0.5.