Error serving on “host”: “0.0.0.0”

usage
solved

(Víctor Peinado) #1

Hi,

I’m running a prodigy instance on an Azure machine (Ubuntu 18.04.1, virtualenv with Python 3.6.5 and prodigy-1.5.1) and I’d like to access the UI from another computer.

My $HOME/.prodigy/prodigy.json contains only these lines:
{
“theme”: “spacy”,
“port”: 8082,
“host”: “0.0.0.0”,
“show_stats”: true,
“show_flag”: true,
}

But I’m unable to access the prodigy interface and I don’t know what else to check. Is there any logs? Any other recommentations? Thanks!

PS.: Using ngrok works perfectly.


(Matthew Honnibal) #2

@vitojph You probably need to open that port in your Azure instance. On AWS and GCP they firewall everything by default; I’m guessing Azure will do the same thing.


(Víctor Peinado) #3

Thanks @honnibal. It seems clearly a problem with the port, which is supposed to be open but somehow blocking prodigy.

There’s nothing wrong in my prodigy settings, then :slight_smile:


(Aakash) #4

@vitojph - did you solve this issue?

@honnibal -
I believe the server opens a tcp connection to 8080 port. I am using paperspace and have a private IP & a public IP. I changed the host configuration in the config file (to the both the IPs) but I can’t open the annotation page from my local browser.

I am running the news headlines example given on your website (NER.teach )


(Matthew Honnibal) #5

@skyprince999 Are you able to host other web services from port 8080? Try running something like the Python SimpleHTTPServer to see if you can access it.