Error occur with execution pos.batch_train, pos.train_curve

Hi, I’ve made successful pos.teach, pos.make-gold, results into dataset.

But suddenly when I tried to train a model using pos.batch-train, or pos.train-curve, it wasn’t working at all with the same error of below link

[Errors with pos.teach and pos.batch-train.]

so as they said, I just remove the code from the very simply, and it was looked working seamlessly on first, but I have still annoyed by below error message, I couldn’t find where that problem is coming from

can someone help me out?

Just to confirm: Are you using the latest version of Prodigy, v1.5.1? The recent version introduced a few changes to the POS recipes, so if you’re still on the previous version, it might be related to that. You could also try adding a print statement to see which examples it fails on, and double-check that all examples in your set are POS annotations in the expected format.

Thank you for such fast response and diagnosis, let me try then!! :crazy_face: