how to run more epoch in prodigy ?

hi @Mohammad!

That's a great question!

Actually, you may want to modify patience because it's likely spaCy's early stopping mechanism is what's holding you back:

python -m prodigy train --ner ner_dataset --training.patience=0

patience controls early-stopping, i.e., the number of steps to continue without improvement before stopping. When you set it as 0, you disable early stopping.

By default, Prodigy enables unlimited epochs, i.e., spaCy's max_epochs are set to 0 by default with prodigy train. As a second lever, you may want to modify spaCy's max_steps which isn't set to unlimited. This can be modified similarly with --training.max_steps=X

This post provides a good background on setting max_steps:

And this spaCy GitHub discussions provides a good explanation of the difference between patience, max_steps, and max_epochs: