Custom Parser Model loading error

Hi I tried loading a custom parsing model through spacy but I get a FileNotFoundError:/vocab/lexemes.bin.
I even tried forcefully linking with the 'en' model using python -m spacy link en_core_web_md en --force as given in the link, But nothing really seemed to work.
The spacy version I am using is 2.3.4.
Please help me out.

What does spacy.__version__ show in your environment?

From the error message it looks like you're trying to load a v2.3 model with spacy v2.2 (or earlier).

Hi, the spacy.version = 2.3.4 in my environment. I have also verified that all installed models are compatible with the spaCy version I have

I'm very sure that spacy v2.3.4 won't try to open a file called vocab/lexemes.bin. Just to double-check can you add a cell to your notebook that runs !python -m spacy info?

Another possibility: if you upgraded spacy in this venv, it's also possible that some older files didn't get cleaned up correctly by pip, so if you're still stuck, try creating a brand new virtual environment and installing spacy again to test to make sure it's not something with the virtual environment.