split_sentences not working when min_length is set

I tried to play with different values of min_length parameter as it is shown in the documentation:

stream = split_sentences(nlp, stream, min_length=length)

The text was splitted only in case of min_length=False. In other cases split_sentences does not split the sentences. I tried even min_length=1, but no luck.

Thanks for the report and sorry about that – will look into this! It could either be a side-effect of the recent changes to the split_sentences helper, or the value is overwritten by the split_sents_threshold config setting where it shouldn’t be.

Ok, just tested it and I think what happened is that min_length was accidentally acting like max_length :woman_facepalming: Already fixed this for the next release!